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General Safety Summary

General Safety Summary
Review the following safety precautions to avoid injury and prevent damage to this product or any products connected to it.

To avoid potential hazards, use this product only as specified.

Only qualified personnel should perform service procedures.

While using this product, you may need to access other parts of a larger system. Read the safety sections of the other
component manuals for warnings and cautions related to operating the system.

To Avoid Fire or Personal Injury
Connect and Disconnect Properly. Connect the probe output to the measurement instrument before connecting the
probe to the circuit under test. Connect the probe reference lead to the circuit under test before connecting the probe
input. Disconnect the probe input and the probe reference lead from the circuit under test before disconnecting the probe
from the measurement instrument.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings and markings on the product. Consult
the product manual for further ratings information before making connections to the product.

Do not apply a potential to any terminal, including the common terminal, that exceeds the maximum rating of that terminal.

Do Not Operate Without Covers. Do not operate this product with covers or panels removed.

Do Not Operate With Suspected Failures. If you suspect that there is damage to this product, have it inspected by
qualified service personnel.

Avoid Exposed Circuitry. Do not touch exposed connections and components when power is present.

Do Not Operate in Wet/Damp Conditions.

Do Not Operate in an Explosive Atmosphere.

Keep Product Surfaces Clean and Dry.

Terms in this Manual
These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in damage to this product or other property.
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Preface

Preface
The TDSHT3 HDMI Compliance Test Software is a High Definition Multimedia Interface (HDMI) Compliance Test Solution,
which runs on a Tektronix oscilloscope. This software helps you perform HDMI physical layer validation and compliance
testing.

NOTE. You will be provided with two TDSHT3 applications, one supporting CTS 1.2a specification displayed as TDSHT3
and the other supporting CTS 1.3b1 specification displayed as TDSHT3v1.3. Both these applications can be loaded onto
the oscilloscope but you can run only one application at a time. For more information on TDSHT3 supporting CTS1.2a
specification refer to the TDSHT3 HDMI Quick Start User Manual (Tektronix part number: 071-1961-01).

Key Features
Conformance to HDMI 1.3a standards and test specifications (CTS version 1.3b1) ensures reliable results

Complete validation to standards with wide range of tests for source, sink, and cable devices

Accurate source tests using precise measurement techniques

Dependable sink tests with closed-loop measurements that eliminate nonlinearities in test setup

Automated sink and cable tests with remote control of signal sources

Automatic mask fit, measurements, and pass or fail notification

In-depth analysis with statistical analysis and mask margins

One-button selection of multiple tests

One-button csv-format summary and HTML consolidated reports

Complete compliance solution with an elaborate test fixture, signal sources, and TDR

Source Single-Ended tests can be performed on two lanes

Source Differential and Cable Eye diagram tests can be performed on all four lanes: Clock, Data0, Data1, and Data2

iv TDSHT3 HDMI Compliance Test Software Quick Start User Manual
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Documentation
This manual describes the installation and basic operation of the TSDHT3 software. For more detailed information, see the
online help. The following information is available for this product:

TDSHT3 Online Help

Start > Programs > TekApplications > TDSHT3v1-3 > Help
TDSHT3 Online Help (PDF)
TDSHT3 Quick Start User Manual,
English (PDF)
TDSHT3 Quick Start User Manual,
Japanese (PDF)
TDSHT3 Quick Reference Card,
Source Test (PDF)
TDSHT3 Quick Reference Card,
Sink Test (PDF) C:\ProgramFiles\TekApplications\TDSHT3v1-3\Manuals www.tektronix.com/manuals
Installation Manual: Optional
Application Software on
Windows-Based Oscilloscopes

Software Upgrades
Periodic software upgrades may become available. Note that the software is only operational if you have a valid option
key for the specific oscilloscope model and serial number.

To check for upgrades:

1. Go to www.tektronix.com/software.

2. Enter the product name (TDSHT3).

TDSHT3 HDMI Compliance Test Software Quick Start User Manual v
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Install the Software

Install the Software
The TDSHT3 software must be installed on a Tektronix oscilloscope.

The 4-Channel feature allows you to perform Source/Cable tests on all four lanes (Clock, Data0, Data1, and Data2). The
application generates a comprehensive test report for all channels when a measurement completes. It uses the real time
capability of the DPO series oscilloscopes and reduces the testing time. It supports the following oscilloscopes:

DPO70804 and DSA70804 (recommended)

DPO71254 and DSA71254

DPO71604 and DSA71604

DPO72004 and DSA72004

This version of the TDSHT3 software also works on the following oscilloscopes but the 4-Channel feature is not supported:

TDS7254 and TDS7254B

TDS7404 and TDS7404B

CSA7404 and CSA7404B

TDS7704B

TDS6604B

TDS6804B

TDS6124C

TDS6154C

DPO70404 and DSA70404

DPO70604 and DSA70604

Before Installation
TekVisa must be installed on the oscilloscope. If you do not have TekVisa, you can download it from the Tektronix Web
site, in the same location as for Software Upgrades. (See page v, Software Upgrades.)

Please read the Readme.txt file on the product software CD before you install the software.

Installation
1. Close all applications.

2. Insert the product software CD into the CD drive of the oscilloscope.

3. The installation wizard will guide you through the installation. If this is a version upgrade, the existing software will be
automatically removed before the new version is installed.

4. The software files will be installed at C:\Program Files\TekApplications\TDSHT3v1–3.

TDSHT3 HDMI Compliance Test Software Quick Start User Manual 1



Install the Software

Connect to the Oscilloscope
Each test requires specific equipment setups and specific test adapters. Click More within the connect pane to see how to
connect the device under test and test equipment to your oscilloscope. The following test adapters are required, depending
on the tests that you will be running:

ET-HDMI-TPA-R, available from Efficere Technologies (recommended)

ET-HDMI-TPA-P, available from Efficere Technologies (recommended)

The test fixtures mentioned below can only work for limited HDMI resolutions.

Tektronix HDMI TPA-P-DI (for Differential Source tests except Eye Diagram)

Tektronix HDMI TPA-P-SE (for Single-Ended Source tests)

Tektronix HDMI TPA-P-TDR (for TDR tests) and Source tests (Eye Diagram)

Tektronix HDMI TPA-R-DI (for Cable tests and Sink tests)

Tektronix HDMI TPA-R-SE (for Cable tests and Sink tests)

Tektronix HDMI TPA-R-TDR (for TDR tests and Sink tests)

2 TDSHT3 HDMI Compliance Test Software Quick Start User Manual



Install the Software

Start the Software
To start the TDSHT3 software:

1. For TDS7000-series oscilloscopes,
select File > Run application > HDMI
Compliance Test Software(1.3).

2. For TDS B- and TDS C-series
oscilloscopes, select App > HDMI
Compliance Test Software(1.3).

TDSHT3 HDMI Compliance Test Software Quick Start User Manual 3



Install the Software

3. For DPO70000 and DSA70000-series
oscilloscopes, select Analyze > HDMI
Compliance Test Software(1.3).

4. The oscilloscope display resizes to fit in
the upper part of the screen.

5. The software displays in the lower part of
the screen.

NOTE. To ensure accurate results, calibrate the probes and the oscilloscope before you run tests.
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Install the Software

Calibrate the Probes and
Oscilloscope
6. Click Utilities > Instrument Calibration

to begin calibrating the oscilloscope for
signal path compensation.

7. Click Calibrate.

8. Select Vertical > Probe Cal to begin
calibrating the probes.

9. Connect the probe calibration signal to
the probe.

10. Click Calibrate Probe.

TDSHT3 HDMI Compliance Test Software Quick Start User Manual 5
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Close the Software
1. Select File > Exit.

2. You can also click the exit icon.
Using other methods to exit the software
will result in abnormal termination.

3. When you exit the software, you
can restore the oscilloscope to the
settings that were in place before the
TDSHT3 software changed them.
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Get Acquainted with the Software

Get Acquainted with the Software

Use the Interface
Use a keyboard, mouse, or touch screen to make selections in the TDSHT3 software.

Use menus, check boxes, and on-screen buttons to control the software functions. Use Microsoft Windows techniques to
navigate menus and select or clear check boxes.

Virtual Keyboard

1. Click New.

2. Clear the existing text and type the new
text.

3. Click Enter to confirm your selection.

NOTE. You must click Enter on the virtual keyboard; otherwise your selections are not valid.
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Get Acquainted with the Software

Virtual Keypad

1. Click any number box.

2. Click the keypad icon.

3. Clear existing value and enter the value
desired.

4. Select a unit of measure.

5. Click Enter to confirm your selection.

NOTE. You must click Enter on the virtual keypad; otherwise your selections are not valid.
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Get Acquainted with the Software

General Purpose Knob

1. Click any number box to display the
connection to one of the general purpose
knobs.

2. Turn the corresponding knob on the
oscilloscope front panel to adjust the
value for the selected parameter.

3. For better resolution, press the FINE
button.
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Set Preferences
1. From the TDSHT3 software menu bar,

click File > Preferences, and then select
an option.

2. Click the option again to clear the
selection.

Option Description
Position Eye Mask in Center Selected: Positions the mask at the center of the eye diagram.

Cleared: Positions the mask to the left of the eye diagram.
Acquisition Alert Message Selected: An alert prompts you to specify oscilloscope settings with which

to run the test.
Cleared: TDSHT3 software selects oscilloscope settings.

Jitter Tolerance (No calibration) Selected: Application will not run the jitter calibration test for Sink Jitter
Tolerance measurements.
Cleared: Application will run the jitter calibration test for Sink Jitter
Tolerance measurements.

Single Ended (With 50 ohm term) This option can be selected only when the negative input of the probe is
terminated with the 50 ohm terminator.
Selected: Application will run the single-ended measurements as though
50 ohm termination is connected.
Cleared: Application will run the single-ended measurements without
50 ohm termination.

Set the probe control to internal 3.3V This option is applicable to Source measurements on DPO/DSA
oscilloscopes with P7313 probes.
Selected: Application sets the probe control to internal and sets voltage
to 3.3 V.
Cleared: Application sets the probe control to Auto.
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Get Acquainted with the Software

Hide and Return the TDSHT3 Software
1. Click the hide icon to minimize the

TDSHT3 software and enlarge the
oscilloscope display.

To return to the TDSHT3 software:

2. For TDS7000-series oscilloscopes,
select the APP button.

TDSHT3 HDMI Compliance Test Software Quick Start User Manual 11
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3. For TDS6000B/C and TDS7000/B-series
oscilloscopes, select App > Restore
Application.

4. For DPO70000 series oscilloscopes,
select Analyze > Restore Application.
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Use the TDSHT3 HDMI Software

Use the TDSHT3 HDMI Software

Tests: Process Flow
When you make a test, follow the sequence of actions indicated in steps 1 through 6. Details for each of these actions
are given on the following pages.

1. Select a test.

2. Configure the test parameters.

3. Connect and configure the equipment.

4. View the waveform to verify test signal.

5. Run the test.

6. Interpret the test result.

7. Generate a report.

NOTE. For accurate test results, calibrate the oscilloscope and probes before you begin the tests. (See page 5, Calibrate
the Probes and Oscilloscope.)

Select a Test
1. Click Select.

2. Click the Source, Sink, or Cable tab.

3. Move the mouse near a test name until
the test ID appears. This ID corresponds
to the Test ID in the HDMI Compliance
Test Specifications.

4. Select the test that you want to run.
You can select multiple tests, but they
must all be of the same type.

5. To select all tests of a certain type, click
Select All.
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Configure the Test Parameters
1. Click Configure.

2. Use the virtual keyboard or the general
purpose knob on the oscilloscope front
panel to change the values if necessary.
You can also use the File menu to restore
factory defaults or save and recall your
own configuration settings.

Connect and Configure the Equipment

NOTE. If your test uses remote control, the setup diagram in the online help shows how to connect the test equipment by
using an E-net connection. You can either use this method or you can use the GPIB-B connection. (See page 32, Enable
Remote Control of Test Equipment.) Example tests are shown in the Application Examples section. (See page 20.)

1. Click Connect.

2. Follow the on-screen instructions to
connect and configure the device under
test and the test equipment.

3. Click More to view the online help for
the selected test, which contains a setup
diagram. Connect the test equipment as
shown in the diagram.

4. If the AWG/AFG and DTG are used for
the selected test, select Signal Sources
and configure the test equipment. (See
page 32, Enable Remote Control of Test
Equipment.)
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View the Waveform
1. Click View Waveform (not applicable for

all tests).

2. Verify that the waveform in the upper part
of display is similar to the waveform that
is displayed in the TDSHT3 software.
If the displays are not similar, check your
configuration and connections.

Run the Test
1. Click Run Test.

2. The test will run, displaying a progress
indicator.
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Use the TDSHT3 HDMI Software

Interpret the Test Result
1. When the test completes, the Result

Summary appears. Check to see if the
device passed the test.

means Pass

means Fail

means Error
If the device did not pass the test, use
steps 2 through 8 to solve the problem,
and then rerun the test.

2. Click Result Details for a spreadsheet
with details about the test result.

3. Check the Remarks column. If any error
codes are present, see the online help
for error code descriptions.

NOTE. The parameters in the Result Details dialog box may change depending on the test that you run.
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The software displays the corresponding eye
diagram depending on the option selected
(CK-D0, CK-D1, or CK-D2) in the Data Lane.
For example, CK-D0.
If you ran an eye diagram test, a plot
appears. You can do the following:

4. Save the image to C:\TekApplica-
tions\TDSHT3v1-3\Images (you can also
change this path).

5. Zoom in and out.

6. View the histogram.

7. Move the mask to see the margin of
error.

8. View statistics.

9. Change the plot to half screen size
(which returns the Result Summary).

10. A plot also appears if you ran the clock
jitter test. In this plot, you will find the
peak-to-peak jitter of the clock.

TDSHT3 HDMI Compliance Test Software Quick Start User Manual 17



Use the TDSHT3 HDMI Software

Generate and Print a Report
You can generate and print a summary or detailed report as described here.

Summary
After you have successfully run a test or tests, you can generate a report summary as a CSV file.

1. Click Summary in the execution pane.

2. A message indicates where the report
summary is saved.

3. Open the file and print the report.

Detail
After you run a test, you can generate a report that contains default information or information that you configure.

1. Click Result to begin configuring the
report (or skip to step 8 for defaults).

2. Enter the device details.

3. Enter the resolution at which you
conducted the test (such as VGA, SVGA,
XGA, SXGA, 1080i, or 1080p).

4. Enter the refresh rate at which you
conducted the test (such as 50 Hz or
60 Hz).

5. Select Auto Increment to generate a
new report. Selecting this option does
not overwrite the existing report.

6. Click Save As to save the generated
reports. The Save File dialog box is
displayed. You can enter a file name and
save the report.

7. Click Clear Report to clear all reports.
Reports generated between this and the
next successful test run will have no
values.
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Use the TDSHT3 HDMI Software

8. Click Detail in the report pane to
generate the HTML report.
Plots and waveforms are displayed
where ever applicable.

NOTE. The application generates an MHT file that can be opened in Internet Explorer.
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Application Examples

Source: Select All (Differential Tests)
This selection runs a set of tests simultaneously.

Required equipment Example
2 (4 probes if you use four channels)
differential probes; Ground lead

Tektronix P7313SMA/P7350SMA (P7330/P7350/P7380/P7380SMA with
external circuit can only be used with old fixtures);
For P7313SMA probes with DPO/DSA, the internal bias voltage can be
used in place of an external power supply.
Tektronix part number 196-3469-00

1 DC power supply, set to 3.3 V Kenwood PW18-1.8AQ
1 EDID emulator ET−EDID PCB(INFO)/Silicon Image TE9100/Quantum Data 882CA
1 input adapter ET−HDMI −TPA−P available from Efficere Technologies
Probe Calibration and Deskew fixture Tektronix part number 067-1478-XX

1. Click Select.

2. Click the Source tab.

3. Click Select All.

4. Click Configure. Change these values
if needed. (You can generally use the
default values.)
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5. Click Connect.

6. Connect and configure the equipment:

Connect the test equipment as
shown in the setup diagram.

Configure the source DUT to output
the first supported video format.

Connect the Efficere EDID PCB with
the EDID chip or configure the EDID
Emulator for the required resolution
(refer to the EDID Emulator user
manual).
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7. Click View Waveform.
Verify that the oscilloscope displays a
similar waveform to the one displayed by
the TDSHT3 software. If the displays are
not similar, check your configuration and
connections.
To ensure accurate results, deskew the
probes before you run a test.

8. Click Run Test.

9. When the test completes, check the test
results. (See page 16, Interpret the Test
Result.)

10. You can generate reports based on
the tests that you ran. (See page 18,
Generate and Print a Report.)

Sink: Min/Max-Diff Swing Tolerance Test
This test verifies that the sink device properly supports TMDS differential voltages at minimum levels.

Required equipment Example
Digital Timing Generator Tektronix DTG5274 (up to 2.7 Gb)/DTG5334 (up to 3.4 Gb) with DTGM30

output module
8 SMA cables Tektronix part number 174-1341-00, 1 meter, or

Tektronix part number 174-1428-00, 1.5 meters
1 DC power supply, set to 5.0 V Kenwood PW18-1.8AQ
1 input adapter ET−HDMI −TPA−P available from Efficere Technologies
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1. Click Select.

2. Click the Sink tab.

3. Select Min/Max-Diff Swing Tolerance.

4. Click Configure. Change these values
if needed. (You can generally use the
default values.)

5. Select the pattern from the available
options and click Outputs to configure
the DTG Outputs.

6. Click Connect.
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7. Connect and configure the equipment:

Connect the test equipment as
shown in the diagram.

Connect the DTG and oscilloscope.
(See page 32, Enable Remote
Control of Test Equipment.)

8. Click Run Test.

9. Follow the series of on-screen messages.

10. When the test completes, check the test
results. (See page 16, Interpret the Test
Result.)

11. You can generate reports based on
the tests that you ran. (See page 18,
Generate and Print a Report.)

NOTE. When you run sink or cable tests, a warning about GPIB Bus Timing appears. If you are sure that the bus timing
parameter is set to 2 μsec, click OK to continue. Otherwise, click Cancel and change the bus timing parameter. (See
page 37, Set the GPIB Bus Timing.)

Sink: Jitter Tolerance Test
This test verifies that your device supports the maximum allowed TMDS clock jitter.

Required equipment Example
Digital Timing Generator Tektronix DTG5274 (up to 2.7 Gb)/DTG5334 (up to 3.4 Gb) with DTGM30

and DTGM32 (for use with AWG710/AWG710B/AFG3000 only) output
module

Arbitrary Waveform Generator Tektronix AWG710 or AWG710B or AWG7102 (Separate Jitter insertion)
Arbitrary Function Generator Tektronix AFG3102, AFG3022, AFG3252
12 SMA cables Tektronix part number 174-1341-00, 1 meter, or

Tektronix part number 174-1428-00, 1.5 meters
1 cable emulator As described in CTS 1.3b1
2 bias tees Mini-circuits ZFBT-4R2GW
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Required equipment Example
1 DC power supply, set to 5 V Kenwood PW18-1.8AQ
2 input adapters ET−HDMI −TPA−P and ET−HDMI −TPA−R available from Efficere

Technologies

1. Click Select.

2. Click the Sink tab.

3. Select Jitter Tolerance.

4. Click Configure. Change these values
if needed. (You can generally use the
default values.)

5. Select the pattern and jitter insertion type
from the available options, and then click
Outputs to configure the DTG Outputs.

6. Click Connect.
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7. Connect and configure the equipment:

NOTE. In the diagram, the symbol
represents a connection to a biased 50 Ω
termination, such as an input port of an
unoccupied differential SMA probe.

Use Jitter Generation block to
generate a known amount of jitter
(Clock jitter: 0.25 UI, Data jitter:
0.30 UI).

Connect the test fixture to the
oscilloscope for calibration. The
oscilloscope calculates data and
clock jitter inserted due to the cables
and the test fixtures along with the
known amount of jitter.

8. Connect and configure the equipment in
one of the following methods:
Method 1a: DTG−AWG710/AWG710B
for testing resolutions ≤74.25 MHz

Connect the test equipment to the
DTG and AWG as shown in the
setup diagram.

When connecting the test fixture
to the DUT, use a cable emulator
specified for the pixel clock rate
being tested.

Connect the DTG, AWG, and
oscilloscope according to the Enable
Remote Control of Test Equipment
procedure. (See page 32.)

Configure the DUT to receive the
HDMI input signal.
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Method 1b: DTG−AWG710/AWG710B
for testing resolutions >74.25 MHz

Connect the test equipment to the
DTG and AWG as shown in the
setup diagram.

When connecting the test fixture
to the DUT, use a cable emulator
specified for the pixel clock rate
being tested.

Connect the DTG, AWG, and
oscilloscope according to the Enable
Remote Control of Test Equipment
procedure. (See page 32.)

Configure the DUT to receive the
HDMI input signal.

Method 2: DTG−AFG3000 composite
jitter insertion

Connect the test equipment to the
DTG and AFG as shown in the setup
diagram.

When connecting the test fixture
to the DUT, use a cable emulator
specified for the pixel clock rate
being tested.

Connect the DTG, AFG, and
oscilloscope according to the Enable
Remote Control of Test Equipment
procedure. (See page 32.)

Configure the DUT to receive the
HDMI input signal.
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Method 3: DTG−AWG7102 composite
jitter insertion for all frequencies

Connect the test equipment to the
DTG and AWG7102 as shown in the
setup diagram.

When connecting the test fixture
to the DUT, use a cable emulator
specified for the pixel clock rate
being tested.

Connect the DTG, AWG7102, and
oscilloscope according to the Enable
Remote Control of Test Equipment
procedure. (See page 32.)

Configure the DUT to receive the
HDMI input signal.

Method 4: DTG−AWG7102 separate
jitter insertion for all frequencies

Connect the test equipment to the
DTG and AWG7102 as shown in the
setup diagram.

When connecting the test fixture
to the DUT, use a cable emulator
specified for the pixel clock rate
being tested.

Connect the DTG, AWG7102, and
oscilloscope according to the Enable
Remote Control of Test Equipment
procedure. (See page 32.)

Configure the DUT to receive the
HDMI input signal.

9. Click Run Test.

10. Follow the series of on-screen messages.

11. When the test completes, check the test
results. (See page 16, Interpret the Test
Result.)

12. You can generate reports based on
the tests that you ran. (See page 18,
Generate and Print a Report.)

28 TDSHT3 HDMI Compliance Test Software Quick Start User Manual



Application Examples

NOTE. When you run sink or cable tests, a warning about GPIB Bus Timing appears. If you are sure that the bus timing
parameter is set to 2 μsec, click OK to continue. Otherwise, click Cancel and change the bus timing parameter. (See
page 37, Set the GPIB Bus Timing.)

Cable: Eye Diagram Test
Cable Equalizer
The signal degradation of typical passive copper cables increases with the frequency and the length of the cable. To recover
data from such cables, the TDSHT3 applies the reference cable equalizer as specified in the HDMI specification 1.3 to Eye
Diagram measurement when the clock frequency is more than 165 MHz.

This test verifies that the cable assembly outputs a compliant data eye.

Required equipment Example
Digital Timing Generator Tektronix DTG5274 (up to 2.7 Gb)/DTG5334 (up to 3.4 Gb) with three

DTGM30 and DTGM32 (for use with AFG3000 only) output module
2 differential probes; Ground lead Tektronix P7313SMA; Tektronix part number 196-3469-00
Arbitrary Function Generator Tektronix AFG3102, AFG3022, AFG3252
8 SMA cables Tektronix part number 174-1341-00, 1 meter, or

Tektronix part number 174-1428-00 1.5 meters
1 DC power supply, set to 3.3 V Kenwood PW18-1.8AQ
2 input adapters ET−HDMI −TPA−P and ET−HDMI −TPA−R available from Efficere

Technologies

1. Click Select.

2. Click the Cable tab.

3. Click Configure. Change the values
if needed. (You can generally use the
default values.)

Test Points. For the first cable that
you test, select TP1 and TP2 to verify
both the input test signal (TP1) and
the output of the cable (TP2). For
successive cable tests, clear TP1.

CRU. Ensure that PLL (default) is
selected for compliance testing.
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4. Click the DTG Method tab.

Select the pattern and jitter insertion
type from the available options.

Configure the DTG outputs that will
provide the clock and data input
signals.

5. Click the Cable Equalizer tab to select
the configuration options.

6. Click the Rise Time Filter tab to select
the configuration options.

7. Click Connect.
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8. Connect and configure the equipment to
verify the test signal input:

Connect the test equipment as
shown in the TP1 setup diagram.

Connect the DTG and oscilloscope.
(See page 32, Enable Remote
Control of Test Equipment.)

NOTE. In the diagram, the symbol
represents a 50 Ω termination or an unused
probe input.

NOTE. When you run sink or cable tests, a warning about GPIB Bus Timing appears. If you are sure that the bus timing
parameter is set to 2 μsec, click OK to continue. Otherwise, click Cancel and change the bus timing parameter. (See
page 37, Set the GPIB Bus Timing.)
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9. Click Run Test.

10. Follow the series of on-screen
messages.

11. When the test completes, check the
test results. These results confirm that
the test signal input is compliant. (See
page 16, Interpret the Test Result.)

12. Remove the TPA-P-DI adapter and add
the TPA-R-DI adapter as shown in the
diagram.

NOTE. In the diagram, the symbol
represents a 50 Ω termination or an unused
probe input.

13. Add the cable DUT between the
TPA-R-TDR adapters.

14. Click Run Test.

15. When the test completes, check the
test results. Pass indicates HDMI
compliance of the cable DUT. (See
page 16, Interpret the Test Result.)

16. Click Configure and set the test point
to TP2.

17. Replace the cable with another cable
DUT and click Run Test.

18. You can generate reports based on
the tests that you ran. (See page 18,
Generate and Print a Report.)

Enable Remote Control of Test Equipment
If you are using the specified Tektronix DTG and AWG models, the TDSHT3 software can configure the connected test
equipment automatically as you run tests. If you are using another DTG or AWG, you must configure the test equipment
manually.

Use this procedure to:

Connect the AWG and DTG for remote control

Configure the GPIB address for remote control

You will need:
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Tektronix DTG5274 or DTG5334 and Tektronix AWG710 or AWG710B or AFG3000 (two channel model) or AWG7102

Tektronix TDS7000 series oscilloscope, DPO70000 series digital oscilloscope, or DSA70000 series digital oscilloscope

National Instruments GPIB-USB-B with the included software, NI-488.2 for Windows

NI-488.2 Software configuration for TDS series

NOTE. If you already have NI-488.2 installed on your oscilloscope, ensure that you have the version and installation
parameters that are described in step 1. If you do not, then uninstall NI-488.2, and install it according to step 1.

1. Install NI-488.2 for Windows (version 2.1
or later).

During installation:

2. Do not install NI-VISA.

3. Install the Measurement & Automation
Explorer.

4. When prompted, enable the GPIB-USB
interface.

5. Restart the oscilloscope.

NI-Software configuration for DPO70000/DSA70000 series

NOTE. If you are using the NI-Drivers on the DPO70000/DSA70000 series for the first time, perform steps 6 through 14. If
not, perform steps 12 through 14.
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6. In the oscilloscope menu, click
Utilities > GPIB Configuration.

7. In the GPIB configuration, select
Controller. A GPIB Mode Switch dialog
box is displayed.

8. Press OK to restart the oscilloscope.
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9. In the oscilloscope menu, click
Utilities > GPIB Configuration.

10. In the GPIB configuration, select
Talk/Listen. A GPIB mode switch dialog
box is displayed.

11. Press OK to restart the oscilloscope.

You cannot access the NI software from
the Start > Program menu. Instead, go
to C:\Program Files\National

Instruments\NI-488.2\Bin

location.

12. Double-click on the Add GPIB Hardware
to display the Add GPIB Hardware
Wizard.

13. Select the appropriate NI hardware from
the list (select GPIB-USB-B from the list
if it is connected).

14. Press Next and finish the installation.

NOTE. Do not install any NI drivers on the DPO70000 or DSA70000 series oscilloscope because they are preinstalled.
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Connect the Equipment

15. Connect the USB-GPIB controller to the
oscilloscope USB port. The oscilloscope
operating system detects the USB-GPIB
controller and installs the driver for it.

16. Using GPIB cables, connect (stack) the
DTG and AWG/AFG GPIB connectors to
the GPIB port of the GPIB controller.
If your test does not use the AWG/AFG,
connect the GPIB-USB-B between the
oscilloscope and the DTG, omitting the
stacked connector from the AWG/AFG.

Verify the Equipment Connections

17. Open the Measurement & Automation
Explorer that was installed with the
NI-488.2 software.

18. In the Configuration pane, under Devices
and Interfaces, right-click the GPIB
device.

19. Click Scan for Instruments.

20. Note the GPIB Instrument Number and
the Primary Address.

21. Right-click the instrument and click
Communicate with Instrument.

22. Click Query and check that *IDN?
describes the correct equipment.
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Set the GPIB Bus Timing

23. Right-click the GPIB device and click
Properties.

24. Click the Advanced tab.

25. In the Bus Timing list, select 2 μsec.

26. Click OK. (Be sure that you complete
the procedure through step 38, where
you will exit the software and restart the
oscilloscope.)
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Configure the GPIB Address

27. Start the TDSHT3 software.

28. Click Select.

29. Click the Sink tab.

30. Select a Differential test, such as Jitter
Tolerance.

31. Click Connect.

32. Click Signal Sources.

For the Tektronix DTG5274 or DTG5334
generator:

33. Click the DTG tab.

34. Click GPIB.

35. Click the AWG tab and repeat.

36. Click the AFG tab and repeat.

37. Click Test Conn and look for a message
that the connection is successful.

38. Exit the TDSHT3 software and restart
the oscilloscope.
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